Working with files

The file list, located on the right-hand side of the window, is where the Renamer magic happens:

Renamer Window With Files

By default, there are two columns:

Adding files

You can open files in Renamer the following ways:

  1. By dragging them onto the drop area on the right side of the window.
  2. By clicking on the Add/Remove button at the top of the window
  3. By clicking on File > Add Files…
  4. Press ⌘+.

Note: This action can be undone.

Removing selected files

You can remove selected files in the following ways:

  1. Right-click on the file and select Remove.
  2. Click on the - button at the top-right of the window.
  3. Click on File > Remove Selected File.
  4. Press ⌘-.

Note: This action can be undone.

Changing the file order

The files’ order can be redefined by drag-and-dropping them on the list, or by clicking on the columns’ headers to sort in ascending or descending order.

Note: This action can be undone.

Inline file renaming

With Renamer, it’s also possible to directly enter a new name for a selected file in the file list. You can do this in the following ways:

  1. Press Enter/Return.
  2. Double-click on the file.
  3. Right click on the file and select “Edit Name”

Note: This action can be undone.

Using QuickLook on files

Like in Finder, you can use QuickLook on files by pressing the Space bar on a selected file, or by pressing the QuickLook button at the top-right of the window.

File detail column

You can get detailed information on a file by selecting it and then pressing the i button at the top-right of the window.

More table columns

You can add the following file information columns to the file list by clicking on View > Columns: